Bluetooth GPS

Bluetooth GPS-1 Bluetooth GPS-2

Connect to an external bluetooth NMEA compatible GPS device. Mock provider allows other apps to work with the device.
### I always receive questions about how to use this app to connect their Notebook or PC, Mac …etc. I have to clarify that the purpose of this app is to connect the Android device with an external Bluetooth GPS device, in order to “replace” the android’s internal GPS.
@@@@@ For samsung devices @@@@@
If your device crash occasionally, please first turn on the internal GPS before using the app. It is a known problem with some samsung devices.
### Please understand that the app frontend is just a frontend, mainly for controlling and configuration purpose, and providing some handy info. so don’t expect it has many functions, shows every details and in any desired format…etc.
**** Please first enable Allow Mock Locations in Setting ****
* can’t guarantee all device+apps work, pls email me details :)
==========
Now you can start/stop the service from other apps by sending the service or broadcast Intent :
Start – googoo.android.btgps.action.SERVICE_START
Stop – googoo.android.btgps.action.SERVICE_STOP
Toggle – googoo.android.btgps.action.SERIVCE_TOGGLE
* Note: You should first make sure you setup all the preferences and you can start the service correctly through the GUI frontend.
* try the workarounds (in preference) if failed to connect (eg, service discovery fail, connection refused)

Please report error or send me logcat if you got FC or any problems, with screen cap of any error messages, nmea log.
There are thousands combinations of [android version x mobile hardware x bluetooth gps hardware ]. Sorry that it is impossible to provide support on a particular hardware model. Even a GPS-A works with Mobile-A, but GPS-A may not work with Mobile-B, but Mobile-B works with GPS-B. However, after upgraded the android version, this combination does not work anymore, but the other combination works again. I always got such reports. I don’t have any those hardwares, and even for some of them, I never heard before and cannot google any information about them. Hope you understand.

CURRENT VERSION: 1.2.1
REQUIRES ANDROID: 2.1 and up

Download