BowShooter Lite

Awesome timepasser! Very addictive!
Shoot the crazy demons and have fun!

Requirements
Minimum Android version:
Android 1.5
Minimum screen width:
320 dpx
Requires features:
Touchscreen
Requires permissions:
Access network state
Internet
Read phone state
Write external storage

Download